quarta-feira, 31 de maio de 2017

Codificando Batalha Naval em VisualG








Algoritmo "BatalhaNaval"


Var
  MinhaMatriz: Vetor[1..10,1..10] de Caracter
  coluna,linha,navio,boia,lancha,JogadaLinha,JogadaColuna,submarino:inteiro;
  TerminarJogo:Logico;
  
  
procedimento LimparMatriz
inicio
   PARA linha DE 1 ATÉ 10 FAÇA
      PARA coluna DE 1 ATÉ 10 FAÇA
         MinhaMatriz[linha,coluna] := "A"
      FIMPARA
   FIMPARA
fimprocedimento


Inicio
escreval("+++++++++  Batalha Naval  ++++++++++")
LimparMatriz

escreval("+++++++++  Gerando navios, boias, submarinos, lanchas  ++++++++++")

PARA navio DE 1 ATÉ 4 FAÇA
  linha := randi(10)
  coluna := randi(10)
  
  se linha = 0 entao
     linha:= linha + 1
  fimse
  
  se coluna = 0 entao
     coluna:= coluna + 1
  fimse
  
  MinhaMatriz[linha,coluna]:="N"
FIMPARA

PARA boia DE 1 ATÉ 4 FAÇA
  linha := randi(10)
  coluna := randi(10)
  
  se linha = 0 entao
     linha:= linha + 1
  fimse

  se coluna = 0 entao
     coluna:= coluna + 1
  fimse
  
  MinhaMatriz[linha,coluna]:="B"
FIMPARA

PARA submarino DE 1 ATÉ 2 FAÇA
  linha := randi(10)
  coluna := randi(10)

   se linha = 0 entao
     linha:= linha + 1
  fimse

  se coluna = 0 entao
     coluna:= coluna + 1
  fimse

  MinhaMatriz[linha,coluna]:="S"
FIMPARA


PARA lancha DE 1 ATÉ 2 FAÇA
  linha := randi(10)
  coluna := randi(10)

  se linha = 0 entao
     linha:= linha + 1
  fimse

  se coluna = 0 entao
     coluna:= coluna + 1
  fimse

  MinhaMatriz[linha,coluna]:="L"
FIMPARA


LimpaTela
escreval("+++++++++  Iniciando o jogo  ++++++++++")

TerminarJogo:=falso;

Enquanto  nao(TerminarJogo) FAÇA
  escreval("+++++++++  Digite o valor de uma linha (1-10)  ++++++++++")
  Leia(JogadaLinha)

  escreval("+++++++++  Digite o valor de uma coluna (1-10)  ++++++++++")
  Leia(JogadaColuna)
  
  se ((JogadaLinha = 0) E (JogadaColuna = 0)) entao
     TerminarJogo:= verdadeiro;
  senao
    SE ((JogadaLinha >= 1) E (JogadaLinha <=10) E (JogadaColuna >= 1) E (JogadaColuna <=10)) ENTAO

     SE  MinhaMatriz[JogadaLinha,JogadaColuna] = "A" entao
       escreval("+++++++++  Splash  ++++++++++")
     fimse

     se MinhaMatriz[JogadaLinha,JogadaColuna] = "N" entao
         escreval("+++++++++  Navio  ++++++++++")
     fimse

     se MinhaMatriz[JogadaLinha,JogadaColuna] = "B" entao
           escreval("+++++++++  Boia  ++++++++++")
     fimse

     se MinhaMatriz[JogadaLinha,JogadaColuna] = "L" entao
        escreval("+++++++++  Lancha  ++++++++++")
     fimse

     se MinhaMatriz[JogadaLinha,JogadaColuna] = "S" entao
         escreval("+++++++++  Submarino  ++++++++++")
     fimse
     
     MinhaMatriz[JogadaLinha,JogadaColuna]:= "J"
     
  fimse
 fimse
FimEnquanto

Fimalgoritmo



quinta-feira, 2 de fevereiro de 2017

Codificando 2048 para Android



https://upload.wikimedia.org/wikipedia/commons/6/64/2048_Screenshot.png 

Bom dia pessoal. Lá por volta de 2014 um estudante de computação da Itália (Gabriele Cirulli), desenvolveu este jogo, 2048. O objetivo do jogo é chegar ao valor de 2048 em um desses quadros coloridos.

Este game ficou muito conhecido e jogá-lo é viciante. A codificação do mesmo é simples e você pode obter mais informações do jogo aqui e sobre o autor aqui.

Até aquele momento em 2014, não se tinha um versão para Android, IOS, atualmente existem muitas. Naquela oportunidade desenvolvi quase que por completo a codificação para Android, mas não tive mais tempo de tocar o código fonte adiante.

Irei compartilhar esse fontes aqui e agora para quem quiser. O projeto foi codificado no Eclipse

Link dos fontes aqui

Curta o blog Tixplicando no Facebook clicando aqui